summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Kelly <ctk21@cl.cam.ac.uk>2021-03-02 13:22:42 +0000
committerTom Kelly <ctk21@cl.cam.ac.uk>2021-03-02 13:22:42 +0000
commitd410d15310c0d09d08fe1e475d613ff7be0d9d8e (patch)
tree2c467b4e84049b0d45afe86a84fa814546245b35 /configure.ac
parenta9d9d03d7de7f561fbba5c75f307c186745553bd (diff)
parente5c8bee85e7ae2d974069d63528333ffacc1923b (diff)
downloadocaml-d410d15310c0d09d08fe1e475d613ff7be0d9d8e.tar.gz
Merge commit 'e5c8bee85e7ae2d974069d63528333ffacc1923b' into parallel_minor_gc_4_12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e3aa776752..abd64452f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,10 +168,11 @@ AC_SUBST([flexdll_chain])
AC_SUBST([flexlink_flags])
AC_SUBST([PACKLD])
AC_SUBST([stdlib_manpages])
+AC_SUBST([compute_deps])
## Generated files
-AC_CONFIG_FILES([Makefile.common])
+AC_CONFIG_FILES([Makefile.build_config])
AC_CONFIG_FILES([Makefile.config])
AC_CONFIG_FILES([tools/eventlog_metadata])
AC_CONFIG_HEADERS([runtime/caml/m.h])
@@ -215,6 +216,12 @@ AC_ARG_ENABLE([debugger],
[],
[enable_debugger=auto])
+AC_ARG_ENABLE([dependency-generation],
+ [AS_HELP_STRING([--disable-dependency-generation],
+ [do not compute dependency information for C sources])],
+ [],
+ [enable_dependency_generation=auto])
+
AC_ARG_VAR([DLLIBS],
[which libraries to use (in addition to -ldl) to load dynamic libs])
@@ -424,6 +431,27 @@ AS_IF([test x"$host_os" = "xwindows"],[host_os=mingw])
LT_INIT
host_os=$old_host_os
+AS_CASE([$host],
+ [*-pc-windows],
+ [AC_CHECK_TOOLS(
+ [DEP_CC],
+ [$DEP_CC gcc cc x86_64-w64-mingw32-gcc i686-w64-mingw32-gcc],
+ [false])],
+ [DEP_CC="$CC"])
+
+AS_CASE([$enable_dependency_generation],
+ [yes],
+ [AS_IF([test "$DEP_CC" = "false"],
+ [AC_MSG_ERROR(m4_normalize([The MSVC ports cannot generate dependency
+ information. Install gcc (or another CC-like compiler)]))],
+ [compute_deps=true])],
+ [no], [compute_deps=false],
+ [AS_IF([test -e .git],
+ [AS_IF([test "$DEP_CC" = "false"],
+ [compute_deps=false],
+ [compute_deps=true])],
+ [compute_deps=false])])
+
# Extracting information from libtool's configuration
AS_IF([test -n "$RANLIB" ],
[RANLIBCMD="$RANLIB"],