summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2011-02-23 16:49:44 -0300
committerDenis Kenzior <denkenz@gmail.com>2011-02-23 17:27:46 -0600
commit8a909a6ef9482341eb8d8928453bb5a73ac3541e (patch)
tree0b53f4e5b5c5cfdd92c21078ef50b5ce9b5e716d /Makefile.am
parent2ce775c106bcb95d1356fecf8efdb9ec9ac5c3ae (diff)
downloadofono-8a909a6ef9482341eb8d8928453bb5a73ac3541e.tar.gz
tools: add client to receive location reporting
As of now there's no support for fd-passing in D-Bus Python bindings, hence a small C client is needed in order to test location-reporting atom.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5bf4fbcd..5650a720 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -556,13 +556,16 @@ unit_test_caif_LDADD = @GLIB_LIBS@
unit_objects += $(unit_test_caif_OBJECTS)
if TOOLS
-noinst_PROGRAMS += tools/huawei-audio tools/auto-enable
+noinst_PROGRAMS += tools/huawei-audio tools/auto-enable tools/get-location
tools_huawei_audio_SOURCES = $(gdbus_sources) tools/huawei-audio.c
tools_huawei_audio_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
tools_auto_enable_SOURCES = $(gdbus_sources) tools/auto-enable.c
tools_auto_enable_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
+
+tools_get_location_SOURCES = tools/get-location.c
+tools_get_location_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
endif
noinst_PROGRAMS += gatchat/gsmdial gatchat/test-server gatchat/test-qcdm