summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@kernel.org>2019-05-21 14:35:40 +0300
committerDenis Kenzior <denkenz@gmail.com>2019-05-22 08:43:57 -0500
commit8bde9f095af8450cf9e8af5b31f316975f08f2f6 (patch)
treea0f364dc9a4946c2901a4c30ccd8c1623b8db143 /Makefile.am
parent48e31f9fc3cf3c486c3d27a67b2687f6df0c5c71 (diff)
downloadofono-8bde9f095af8450cf9e8af5b31f316975f08f2f6.tar.gz
build: Don't overwrite src_ofonod_DEPENDENCIES
src_ofonod_DEPENDENCIES did overwrite the dependencies automatically generated from src_ofonod_LDADD with incomplete dependencies. This fixes the following build error: ... CCLD src/ofonod libtool: error: cannot find the library 'gdbus/libgdbus-internal.la' or unhandled argument 'gdbus/libgdbus-internal.la' make: *** [Makefile:3448: src/ofonod] Error 1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d2e310d5..5edc4488 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,12 +6,10 @@ noinst_LTLIBRARIES =
if EXTERNAL_ELL
ell_cflags = @ELL_CFLAGS@
ell_ldadd = @ELL_LIBS@
-ell_dependencies =
ell_built_sources =
else
ell_cflags =
ell_ldadd = ell/libell-internal.la
-ell_dependencies = $(ell_ldadd)
ell_built_sources = ell/internal ell/ell.h
noinst_LTLIBRARIES += ell/libell-internal.la
@@ -729,8 +727,6 @@ src_ofonod_LDADD = gdbus/libgdbus-internal.la $(builtin_libadd) $(ell_ldadd) \
src_ofonod_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/ofono.ver
-src_ofonod_DEPENDENCIES = $(ell_dependencies)
-
BUILT_SOURCES = $(local_headers) $(ell_built_sources) src/builtin.h
CLEANFILES = $(BUILT_SOURCES) $(rules_DATA)