summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVincent Cesson <vincent.cesson@smile.fr>2017-01-18 12:32:04 +0100
committerDenis Kenzior <denkenz@gmail.com>2017-01-19 13:34:36 -0600
commitc0c7c92a82224ed23f5fce245a8570601994a888 (patch)
tree0d994b13024fefd7d2ed9a8a2d431e4204d0fb05 /Makefile.am
parente8c80cbe8b32827f1fdff1a360cc5611e2b86159 (diff)
downloadofono-c0c7c92a82224ed23f5fce245a8570601994a888.tar.gz
drivers: Add gemaltomodem driver to handle GNSS
Add a new location-reporting driver for Gemalto Cinterion modems based on telit implementation + use it in gemalto plugin. It supports activation of GNSS engine (Request) with command AT^SGPSC. This driver is tested on PHS8. NMEA frames are accessible on /dev/ttyUSB1.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a87c8922..f76971ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -388,6 +388,12 @@ builtin_sources += drivers/atmodem/atutil.h \
drivers/ubloxmodem/lte.c
+builtin_modules += gemaltomodem
+builtin_sources += drivers/atmodem/atutil.h \
+ drivers/gemaltomodem/gemaltomodem.h \
+ drivers/gemaltomodem/gemaltomodem.c \
+ drivers/gemaltomodem/location-reporting.c
+
if PHONESIM
builtin_modules += phonesim