summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonas Bonn <jonas@southpole.se>2018-03-05 13:31:01 +0100
committerDenis Kenzior <denkenz@gmail.com>2018-03-05 11:32:30 -0600
commitf2e38a6b4216437b084fd866fe406aa71b5d5f7f (patch)
tree9c6add481eb3ca3c8cea52ad1ce448cc25dbcd4b /Makefile.am
parentdca9071ffe3c044816c8b0ff692d6aaad0421ab1 (diff)
downloadofono-f2e38a6b4216437b084fd866fe406aa71b5d5f7f.tar.gz
qmi: add LTE atom driver
This patch adds an LTE atom for QMI modems. This atom sets the APN that the LTE default bearer should use when establishing its PDP context. This APN needs to be set on the 'default' profile so the atom queries which profile is the default and resets it before allowing the APN to be set. Once configured, the default profile settings are used when the modem connects to the network; for this reason, the LTE atom needs to be instantiated in post_sim, before the modem is set online.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d790a215..a921bd2b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -234,6 +234,7 @@ builtin_sources += $(qmi_sources) \
drivers/qmimodem/ussd.c \
drivers/qmimodem/gprs.c \
drivers/qmimodem/gprs-context.c \
+ drivers/qmimodem/lte.c \
drivers/qmimodem/radio-settings.c \
drivers/qmimodem/location-reporting.c \
drivers/qmimodem/netmon.c