summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2011-01-09 11:04:58 -0800
committerMarcel Holtmann <marcel@holtmann.org>2011-01-09 11:04:58 -0800
commit0bcbcc8db6b040db0638468769b40c89d23ddcd7 (patch)
tree638f864db78c3ed645b6b3f0289eebf20e8b51e5 /configure.ac
parentfe9bb02484ee38711dd9c1f6c8d2d4bf111cb1b7 (diff)
downloadofono-0bcbcc8db6b040db0638468769b40c89d23ddcd7.tar.gz
build: Add configure option for building tools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c33780f8..7a2ca790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,16 @@ AC_SUBST(UDEV_CFLAGS)
AC_SUBST(UDEV_LIBS)
AM_CONDITIONAL(UDEV, test "${enable_udev}" = "yes")
+AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools],
+ [enable testing tools]), [enable_tools=${enableval}])
+if (test "${enable_tools}" = "yes"); then
+ PKG_CHECK_MODULES(USB, libusb-1.0, dummy=yes,
+ AC_MSG_ERROR(USB library is required))
+ AC_SUBST(USB_CFLAGS)
+ AC_SUBST(USB_LIBS)
+fi
+AM_CONDITIONAL(TOOLS, test "${enable_tools}" = "yes")
+
AC_ARG_ENABLE(atmodem, AC_HELP_STRING([--disable-atmodem],
[disable ETSI AT modem support]),
[enable_atmodem=${enableval}])