summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2018-10-31 19:58:10 +0100
committerMarcel Holtmann <marcel@holtmann.org>2018-10-31 19:58:10 +0100
commit8452a7f34907472c5e21c334673afd10df409eef (patch)
tree242b2afdfe2a4838f054cf9b871d932977032674 /configure.ac
parent814f7fc7442d5886b71f6ca6dd2b006eda896f00 (diff)
downloadofono-8452a7f34907472c5e21c334673afd10df409eef.tar.gz
build: Add support for internal and external Embedded Linux library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 12 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 5a8fb6f5..026c9a6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,11 @@ AC_ARG_ENABLE(qmimodem, AC_HELP_STRING([--disable-qmimodem],
[enable_qmimodem=${enableval}])
AM_CONDITIONAL(QMIMODEM, test "${enable_qmimodem}" != "no")
+AC_ARG_ENABLE(mbimmodem, AC_HELP_STRING([--disable-mbimmodem],
+ [disable MBIM modem support]),
+ [enable_mbimmodem=${enableval}])
+AM_CONDITIONAL(MBIMMODEM, test "${enable_mbimmodem}" != "no")
+
AC_ARG_ENABLE(bluetooth, AC_HELP_STRING([--disable-bluetooth],
[disable BlueZ 4 and BlueZ 5 plugins support]),
[enable_bluetooth=${enableval}])
@@ -207,24 +212,16 @@ AC_ARG_ENABLE(upower, AC_HELP_STRING([--disable-upower],
[enable_upower=${enableval}])
AM_CONDITIONAL(UPOWER, test "${enable_power}" != "no")
-AC_ARG_ENABLE(mbimmodem, AC_HELP_STRING([--enable-mbimmodem],
- [enable MBIM based modem support]),
- [enable_mbimmodem=${enableval}])
-
-AC_ARG_ENABLE(ell, AC_HELP_STRING([--enable-ell],
- [enable support for ell]),
- [enable_ell=${enableval}])
-
-if (test "${enable_ell}" = "yes"); then
- AC_DEFINE(HAVE_ELL, 1, [Defined if Ell is enabled])
- PKG_CHECK_MODULES(ELL, ell >= 0.2, dummy=yes,
- AC_MSG_ERROR(ell library >= 0.2 is required))
+AC_ARG_ENABLE([external_ell], AC_HELP_STRING([--enable-external-ell],
+ [enable external Embedded Linux library]),
+ [enable_external_ell=${enableval}])
+if (test "${enable_external_ell}" = "yes"); then
+ PKG_CHECK_MODULES(ELL, ell >= 0.12, dummy=yes,
+ AC_MSG_ERROR(Embedded Linux library >= 0.12 is required))
AC_SUBST(ELL_CFLAGS)
AC_SUBST(ELL_LIBS)
fi
-
-AM_CONDITIONAL(MBIMMODEM, test "${enable_ell}" != "no" && test "${enable_mbimmodem}" = "yes")
-AM_CONDITIONAL(ELL, test "${enable_ell}" != "no")
+AM_CONDITIONAL(EXTERNAL_ELL, test "${enable_external_ell}" = "yes")
AC_ARG_ENABLE(datafiles, AC_HELP_STRING([--disable-datafiles],
[do not install configuration and data files]),