summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcel Metz <mmetz@adrian-broher.net>2016-03-08 10:56:04 +0100
committerMarcel Metz <mmetz@adrian-broher.net>2016-04-01 10:46:38 +0200
commite44f1f9a4c8612c4aba821ea65a8e2c519a20bd5 (patch)
tree6cd7eaf217506b6071248fe417c0bf51d1040907 /CMakeLists.txt
parentb85b8596c83df4c14d4ea76fa11385c031a08cba (diff)
downloadogg-git-e44f1f9a4c8612c4aba821ea65a8e2c519a20bd5.tar.gz
CMake: Set install MacOSX Framework location to `CMAKE_INSTALL_PREFIX`
Users should be able to install the MacOSX Framework by pointing CMAKE_INSTALL_PREFIX to the corresponding directory. For example to install into `/Library/Frameworks` configure with cmake -DCMAKE_INSTALL_PREFIX=/Library/Frameworks <build dir>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14c96f1..78b6604 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,7 +108,7 @@ install(TARGETS ogg
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- FRAMEWORK DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ FRAMEWORK DESTINATION ${CMAKE_INSTALL_PREFIX}
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ogg
)
install(FILES ogg.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)