summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalph Giles <giles@thaumas.net>2017-06-16 14:08:29 -0700
committerRalph Giles <giles@thaumas.net>2017-06-16 21:15:16 -0700
commitf253dd721ec2dc909b197faa770995ce7c6bfcfa (patch)
tree5e668322f8122fceaa129a652cafe20449a9b782 /CMakeLists.txt
parent14920bae036a56166b3289afd18d67739f015495 (diff)
downloadogg-git-f253dd721ec2dc909b197faa770995ce7c6bfcfa.tar.gz
cmake: fix install target.
The previous commit changed the generated source file location without updating the installed-file list or include directories, breaking installation and downstream integration tests. Adding the include directory doesn't seem to be necessary on macOS, but even the initial build step fails on Linux without it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c21e5ce..5ab14a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ set(SIZE64 int64_t)
configure_file(include/ogg/config_types.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/ogg/config_types.h @ONLY)
set(OGG_HEADERS
- include/ogg/config_types.h
+ ${CMAKE_CURRENT_BINARY_DIR}/include/ogg/config_types.h
include/ogg/ogg.h
include/ogg/os_types.h
)
@@ -80,7 +80,7 @@ if(BUILD_FRAMEWORK)
set(BUILD_SHARED_LIBS TRUE)
endif()
-include_directories(include)
+include_directories(include ${CMAKE_CURRENT_BINARY_DIR}/include)
add_library(ogg ${OGG_HEADERS} ${OGG_SOURCES})
get_version_info(OGG_VERSION_INFO "LIB_CURRENT" "LIB_AGE" "LIB_REVISION")
@@ -111,4 +111,6 @@ install(TARGETS ogg
FRAMEWORK DESTINATION ${CMAKE_INSTALL_PREFIX}
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ogg
)
-install(FILES ogg.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ogg.pc
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig
+)