summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomasvs@xiph.org>2005-09-07 19:04:01 +0000
committerThomas Vander Stichele <thomasvs@xiph.org>2005-09-07 19:04:01 +0000
commit248184ce982668e867030c9e48ff702a8a96ddd0 (patch)
treecd6a9fe092203df688b40420e13d4c5b7182ac2d /Makefile.am
parent6da95bab7a808e065a08e3f3ddd33debc925dd31 (diff)
downloadogg-git-248184ce982668e867030c9e48ff702a8a96ddd0.tar.gz
get rid of the macosx hack by disting debian from toplevel Makefile.am
svn path=/trunk/ogg/; revision=9990
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 085a680..5297d70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
AUTOMAKE_OPTIONS = foreign 1.6 dist-zip
-SUBDIRS = src include doc win32 debian
+SUBDIRS = src include doc win32
m4datadir = $(datadir)/aclocal
m4data_DATA = ogg.m4
@@ -10,12 +10,18 @@ m4data_DATA = ogg.m4
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = ogg.pc
+# we include the whole debian/ dir in EXTRA_DIST because there's a problem
+# with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
+# to pick up on the lowercase changelog file and add ChangeLog to DIST_COMMON
+# because of it, breaking make dist. This works just as well.
EXTRA_DIST = README AUTHORS CHANGES COPYING \
libogg.spec libogg.spec.in \
ogg.m4 ogg.pc.in ogg-uninstalled.pc.in \
- macos macosx
+ macos macosx debian
dist-hook:
+ rm -rf `find $(distdir)/debian -name .svn`
+ rm -rf `find $(distdir)/debian -name "Makefile*"`
rm -rf `find $(distdir)/macos -name CVS`
rm -rf `find $(distdir)/macosx -name CVS`