summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalph Giles <giles@xiph.org>2005-11-28 04:37:31 +0000
committerRalph Giles <giles@xiph.org>2005-11-28 04:37:31 +0000
commit6602c3aeac34e4906e399c5c1caca69369e678a9 (patch)
tree7b02229ca53a4620a572cab78d8e711b9cdc0763 /Makefile.am
parent3daf430dd4186a450caaaa8bd19b3ef2942cfe40 (diff)
downloadogg-git-6602c3aeac34e4906e399c5c1caca69369e678a9.tar.gz
Remove win32/Makefile.am in favor of just including the whole dir, like
we do for the MacOS build stuff. If there was a reason for doing it this way, I don't remember what it was. The reason we're switching is that 'make dist' doesn't pull in the new VS2003 project files, and this seems better than adding each specific file all the time. svn path=/trunk/ogg/; revision=10484
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f716c1..62cb799 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
AUTOMAKE_OPTIONS = foreign 1.6 dist-zip
-SUBDIRS = src include doc win32
+SUBDIRS = src include doc
m4datadir = $(datadir)/aclocal
m4data_DATA = ogg.m4
@@ -17,13 +17,14 @@ pkgconfig_DATA = ogg.pc
EXTRA_DIST = README AUTHORS CHANGES COPYING \
libogg.spec libogg.spec.in \
ogg.m4 ogg.pc.in ogg-uninstalled.pc.in \
- macos macosx debian
+ debian macos macosx win32
dist-hook:
rm -rf `find $(distdir)/debian -name .svn`
rm -rf `find $(distdir)/debian -name "Makefile*"`
rm -rf `find $(distdir)/macos -name .svn`
rm -rf `find $(distdir)/macosx -name .svn`
+ rm -rf `find $(distdir)/win32 -name .svn`
debug:
$(MAKE) all CFLAGS="@DEBUG@"