summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalph Giles <giles@xiph.org>2006-01-19 23:31:14 +0000
committerRalph Giles <giles@xiph.org>2006-01-19 23:31:14 +0000
commit8886c89ce8637c7ddf885df899ccf34e708e73e1 (patch)
treeed70ab9ee7a159cf7b93d51123b4cec96a83ae63 /Makefile.am
parent7defbb92454039a3b986924a043bce4def0fb4c7 (diff)
downloadogg-git-8886c89ce8637c7ddf885df899ccf34e708e73e1.tar.gz
Remove the debian subdir from distribution tarballs at the request of
the debian maintainer. svn path=/trunk/ogg/; revision=10740
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 62cb799..9eb7955 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,22 +10,19 @@ m4data_DATA = ogg.m4
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = ogg.pc
-# we include the whole debian/ dir in EXTRA_DIST because there's a problem
-# with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
-# to pick up on the lowercase changelog file and add ChangeLog to DIST_COMMON
-# because of it, breaking make dist. This works just as well.
EXTRA_DIST = README AUTHORS CHANGES COPYING \
libogg.spec libogg.spec.in \
ogg.m4 ogg.pc.in ogg-uninstalled.pc.in \
- debian macos macosx win32
+ macos macosx win32
dist-hook:
- rm -rf `find $(distdir)/debian -name .svn`
- rm -rf `find $(distdir)/debian -name "Makefile*"`
- rm -rf `find $(distdir)/macos -name .svn`
- rm -rf `find $(distdir)/macosx -name .svn`
- rm -rf `find $(distdir)/win32 -name .svn`
-
+ for item in $(EXTRA_DIST); do \
+ if test -d $$item; then \
+ echo -n "cleaning dir $$item for distribution..."; \
+ rm -rf `find $(distdir)/$$item -name .svn`; \
+ echo "OK"; \
+ fi; \
+ done
debug:
$(MAKE) all CFLAGS="@DEBUG@"