summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Matthews <tmatth@videolan.org>2017-09-24 14:18:17 +0200
committerTristan Matthews <tmatth@videolan.org>2017-11-07 18:53:17 -0500
commit862163e51f87fa5bf57b437dd502052da597c723 (patch)
treeceb37c3f97c52d3445f077f1479781ef31a1611f /configure.ac
parentc1daa80c20245c308f26add56991e36fd8954933 (diff)
downloadogg-git-862163e51f87fa5bf57b437dd502052da597c723.tar.gz
configure: add --disable-crc option
Useful for fuzzing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33c88ab..588d2f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,17 @@ if test -z "$SIZE64"; then
AC_MSG_WARN(No 64 bit type found on this platform!)
fi
+AC_ARG_ENABLE([crc],
+ [AS_HELP_STRING([--disable-crc],
+ [Disable CRC in the demuxer)])],,
+ [enable_crc=yes])
+
+AM_CONDITIONAL([DISABLE_CRC], [test "$enable_crc" = "no"])
+
+AS_IF([test "$enable_crc" = "no"],[
+ AC_DEFINE([DISABLE_CRC], [1], [Do not build with CRC])
+])
+
dnl Checks for library functions.
AC_FUNC_MEMCMP