summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Matthews <tmatth@videolan.org>2019-03-06 15:37:31 -0500
committerTristan Matthews <tmatth@videolan.org>2019-03-06 15:39:40 -0500
commitd9089e3710893fdb3a9ea8de2a9ca2cb901954c0 (patch)
tree170e6802433e32acc55d76f82a4c13881276492b /configure.ac
parent0acd32d7cabf7e41cc29ea7c2bbffde969ff1ba0 (diff)
downloadogg-git-d9089e3710893fdb3a9ea8de2a9ca2cb901954c0.tar.gz
configure: add USIZE64 template
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ee29978..a1b2136 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,7 @@ AC_CHECK_SIZEOF(int32_t)
AC_CHECK_SIZEOF(uint32_t)
AC_CHECK_SIZEOF(u_int32_t)
AC_CHECK_SIZEOF(int64_t)
+AC_CHECK_SIZEOF(uint64_t)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
@@ -135,6 +136,13 @@ case 8 in
$ac_cv_sizeof_long_long) SIZE64="long long";;
esac
+case 8 in
+ $ac_cv_sizeof_uint64_t) USIZE64="uint64_t";;
+ $ac_cv_sizeof_unsigned_int) USIZE64="unsigned int";;
+ $ac_cv_sizeof_unsigned_long) USIZE64="unsigned long";;
+ $ac_cv_sizeof_unsigned_long_long) USIZE64="unsigned long long";;
+esac
+
if test -z "$SIZE16"; then
AC_MSG_ERROR(No 16 bit type found on this platform!)
fi
@@ -150,6 +158,9 @@ fi
if test -z "$SIZE64"; then
AC_MSG_WARN(No 64 bit type found on this platform!)
fi
+if test -z "$USIZE64"; then
+ AC_MSG_WARN(No unsigned 64 bit type found on this platform!)
+fi
AC_ARG_ENABLE([crc],
[AS_HELP_STRING([--disable-crc],
@@ -176,6 +187,7 @@ AC_SUBST(USIZE16)
AC_SUBST(SIZE32)
AC_SUBST(USIZE32)
AC_SUBST(SIZE64)
+AC_SUBST(USIZE64)
AC_SUBST(OPT)
AC_SUBST(LIBS)
AC_SUBST(DEBUG)