summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMonty <xiphmont@xiph.org>2009-05-19 23:27:38 +0000
committerMonty <xiphmont@xiph.org>2009-05-19 23:27:38 +0000
commit2847fef44c50bd277aed2200b8e06f7aabb34822 (patch)
treefb4a077fac9b41ecd266b9d2aac9be87401d23eb /configure.in
parent19dbb37556979fa67a5830af3db9efb9503e6eb2 (diff)
downloadogg-2847fef44c50bd277aed2200b8e06f7aabb34822.tar.gz
Update configure script to use new 'legal' names for cache vals (I hate you so much, autofoo)
Update ogg to check the return of all allocs for those on embedded platforms with guarantees non-ovecommit. Be aware that these checks are useless on any modern desktop OS, but that embedded folks with no MMU and a hard heap boundary will benefit. Add one new call to bitpacker that will query a write-mode oggpack_buffer to see if it ran out of memory at some point; there was no other way to add the error reporting in an ABI-compatible manner (and it also allows the writepacker to avoid extra checks; it will just keep going after running out of memory without faulting and state can be queried later). git-svn-id: http://svn.xiph.org/trunk/ogg@16016 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in84
1 files changed, 42 insertions, 42 deletions
diff --git a/configure.in b/configure.in
index 2957d76..d1185b6 100644
--- a/configure.in
+++ b/configure.in
@@ -83,7 +83,7 @@ AC_C_CONST
dnl Check for types
AC_MSG_CHECKING(for int16_t)
-AC_CACHE_VAL(has_int16_t,
+AC_CACHE_VAL(has_cv_int16_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -92,14 +92,14 @@ AC_CACHE_VAL(has_int16_t,
int16_t foo;
int main() {return 0;}
],
-has_int16_t=yes,
-has_int16_t=no,
-has_int16_t=no
+has_cv_int16_t=yes,
+has_cv_int16_t=no,
+has_cv_int16_t=no
)])
-AC_MSG_RESULT($has_int16_t)
+AC_MSG_RESULT($has_cv_int16_t)
AC_MSG_CHECKING(for int32_t)
-AC_CACHE_VAL(has_int32_t,
+AC_CACHE_VAL(has_cv_int32_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -108,14 +108,14 @@ AC_CACHE_VAL(has_int32_t,
int32_t foo;
int main() {return 0;}
],
-has_int32_t=yes,
-has_int32_t=no,
-has_int32_t=no
+has_cv_int32_t=yes,
+has_cv_int32_t=no,
+has_cv_int32_t=no
)])
-AC_MSG_RESULT($has_int32_t)
+AC_MSG_RESULT($has_cv_int32_t)
AC_MSG_CHECKING(for uint32_t)
-AC_CACHE_VAL(has_uint32_t,
+AC_CACHE_VAL(has_cv_uint32_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -124,14 +124,14 @@ AC_CACHE_VAL(has_uint32_t,
uint32_t foo;
int main() {return 0;}
],
-has_uint32_t=yes,
-has_uint32_t=no,
-has_uint32_t=no
+has_cv_uint32_t=yes,
+has_cv_uint32_t=no,
+has_cv_uint32_t=no
)])
-AC_MSG_RESULT($has_uint32_t)
+AC_MSG_RESULT($has_cv_uint32_t)
AC_MSG_CHECKING(for uint16_t)
-AC_CACHE_VAL(has_uint16_t,
+AC_CACHE_VAL(has_cv_uint16_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -140,14 +140,14 @@ AC_CACHE_VAL(has_uint16_t,
uint16_t foo;
int main() {return 0;}
],
-has_uint16_t=yes,
-has_uint16_t=no,
-has_uint16_t=no
+has_cv_uint16_t=yes,
+has_cv_uint16_t=no,
+has_cv_uint16_t=no
)])
-AC_MSG_RESULT($has_uint16_t)
+AC_MSG_RESULT($has_cv_uint16_t)
AC_MSG_CHECKING(for u_int32_t)
-AC_CACHE_VAL(has_u_int32_t,
+AC_CACHE_VAL(has_cv_u_int32_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -156,14 +156,14 @@ AC_CACHE_VAL(has_u_int32_t,
u_int32_t foo;
int main() {return 0;}
],
-has_u_int32_t=yes,
-has_u_int32_t=no,
-has_u_int32_t=no
+has_cv_u_int32_t=yes,
+has_cv_u_int32_t=no,
+has_cv_u_int32_t=no
)])
-AC_MSG_RESULT($has_u_int32_t)
+AC_MSG_RESULT($has_cv_u_int32_t)
AC_MSG_CHECKING(for u_int16_t)
-AC_CACHE_VAL(has_u_int16_t,
+AC_CACHE_VAL(has_cv_u_int16_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -172,14 +172,14 @@ AC_CACHE_VAL(has_u_int16_t,
u_int16_t foo;
int main() {return 0;}
],
-has_u_int16_t=yes,
-has_u_int16_t=no,
-has_u_int16_t=no
+has_cv_u_int16_t=yes,
+has_cv_u_int16_t=no,
+has_cv_u_int16_t=no
)])
-AC_MSG_RESULT($has_u_int16_t)
+AC_MSG_RESULT($has_cv_u_int16_t)
AC_MSG_CHECKING(for int64_t)
-AC_CACHE_VAL(has_int64_t,
+AC_CACHE_VAL(has_cv_int64_t,
[AC_TRY_RUN([
#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
@@ -188,11 +188,11 @@ AC_CACHE_VAL(has_int64_t,
int64_t foo;
int main() {return 0;}
],
-has_int64_t=yes,
-has_int64_t=no,
-has_int64_t=no
+has_cv_int64_t=yes,
+has_cv_int64_t=no,
+has_cv_int64_t=no
)])
-AC_MSG_RESULT($has_int64_t)
+AC_MSG_RESULT($has_cv_int64_t)
AC_CHECK_SIZEOF(short,2)
AC_CHECK_SIZEOF(int,4)
@@ -200,7 +200,7 @@ AC_CHECK_SIZEOF(long,4)
AC_CHECK_SIZEOF(long long,8)
-if test x$has_int16_t = "xyes" ; then
+if test x$has_cv_int16_t = "xyes" ; then
SIZE16="int16_t"
else
case 2 in
@@ -209,7 +209,7 @@ else
esac
fi
-if test x$has_int32_t = "xyes" ; then
+if test x$has_cv_int32_t = "xyes" ; then
SIZE32="int32_t"
else
case 4 in
@@ -219,10 +219,10 @@ else
esac
fi
-if test x$has_uint32_t = "xyes" ; then
+if test x$has_cv_uint32_t = "xyes" ; then
USIZE32="uint32_t"
else
- if test x$has_u_int32_t = "xyes" ; then
+ if test x$has_cv_u_int32_t = "xyes" ; then
USIZE32="u_int32_t"
else
case 4 in
@@ -233,10 +233,10 @@ else
fi
fi
-if test x$has_uint16_t = "xyes" ; then
+if test x$has_cv_uint16_t = "xyes" ; then
USIZE16="uint16_t"
else
- if test x$has_u_int16_t = "xyes" ; then
+ if test x$has_cv_u_int16_t = "xyes" ; then
USIZE16="u_int16_t"
else
case 2 in
@@ -247,7 +247,7 @@ else
fi
fi
-if test x$has_int64_t = "xyes" ; then
+if test x$has_cv_int64_t = "xyes" ; then
SIZE64="int64_t"
else
case 8 in