summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjsquyres <jsquyres@xiph.org>2001-02-28 03:17:17 +0000
committerjsquyres <jsquyres@xiph.org>2001-02-28 03:17:17 +0000
commit4a1452a77ef80ecb87817692265e1fe83fd41acf (patch)
treeef207137690367576698550ddfe1ee6ab8af2077 /configure.in
parentc6e7cfe9bae058366d40de61268a4e0945cdcf06 (diff)
downloadogg-4a1452a77ef80ecb87817692265e1fe83fd41acf.tar.gz
Allow the user to specify their own CFLAGS and LDFLAGS when they run
configure/autogen.sh. If the environment variables CFLAGS and/or LDFLAGS are set, their values are saved and appended to the values that are set in configure.in. Example (csh-style, cope): % setenv CFLAGS -DVORBIS_ROCKS=1 % ./autogen.sh git-svn-id: http://svn.xiph.org/trunk/ogg@1373 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0b6fe0e..073ea48 100644
--- a/configure.in
+++ b/configure.in
@@ -17,6 +17,8 @@ AM_PROG_LIBTOOL
dnl Set some options based on environment
+cflags_save="$CFLAGS"
+ldflags_save="$LDFLAGS"
if test -z "$GCC"; then
case $host in
*-*-irix*)
@@ -59,6 +61,8 @@ else
;;
esac
fi
+CFLAGS="$CFLAGS $cflags_save"
+LDFLAGS="$LDFLAGS $ldflags_save"
dnl Checks for programs.