summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRalph Giles <giles@xiph.org>2009-05-27 13:10:39 +0000
committerRalph Giles <giles@xiph.org>2009-05-27 13:10:39 +0000
commitced5eb8e066d2e3710002aee26e1666c02e352d0 (patch)
tree616c5d84d5b8c96eb6e47b2f7e7372e92f62e6ab /configure.in
parent73d106ebec400572ec4932c1276c17159b04cc4f (diff)
downloadogg-ced5eb8e066d2e3710002aee26e1666c02e352d0.tar.gz
Only pass -mv8 on sparc if the compiler supports it.
Propagated from codec-level configure scripts. git-svn-id: http://svn.xiph.org/trunk/ogg@16054 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4b879ea..8d65a4a 100644
--- a/configure.in
+++ b/configure.in
@@ -50,9 +50,18 @@ else
PROFILE="-Wall -W -pg -g -O20 -ffast-math -fsigned-char"
;;
sparc-sun-*)
- DEBUG="-g -Wall -fsigned-char -mv8"
- CFLAGS="-O20 -ffast-math -fsigned-char -mv8"
- PROFILE="-pg -g -O20 -fsigned-char -mv8"
+ sparc_cpu=""
+ AC_MSG_CHECKING([if gcc supports -mv8])
+ old_cflags="$CFLAGS"
+ CFLAGS="$CFLAGS -mv8"
+ AC_TRY_COMPILE(, [return 0;], [
+ AC_MSG_RESULT([yes])
+ sparc_cpu="-mv8"
+ ])
+ CFLAGS="$old_cflags"
+ DEBUG="-g -Wall -fsigned-char $sparc_cpu"
+ CFLAGS="-O20 -ffast-math -fsigned-char $sparc_cpu"
+ PROFILE="-pg -g -O20 -fsigned-char $sparc_cpu"
;;
*-*-darwin*)
DEBUG="-fno-common -g -Wall -fsigned-char"