summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMonty <xiphmont@xiph.org>2002-09-18 04:42:09 +0000
committerMonty <xiphmont@xiph.org>2002-09-18 04:42:09 +0000
commite8f522f3b09eb42a928c024a25027f5878a43190 (patch)
tree1642133d375b797ac066d17ea7b3a5611f7b9fa0 /configure.in
parent617d013f95cc0767aa17f50088f5b66b7741ba65 (diff)
downloadogg-e8f522f3b09eb42a928c024a25027f5878a43190.tar.gz
Add ogg_uint16_t for Theora
git-svn-id: http://svn.xiph.org/trunk/ogg@3916 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 50 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ad2958b..d620d65 100644
--- a/configure.in
+++ b/configure.in
@@ -127,6 +127,22 @@ has_uint32_t=no
)])
AC_MSG_RESULT($has_uint32_t)
+AC_MSG_CHECKING(for uint16_t)
+AC_CACHE_VAL(has_uint16_t,
+[AC_TRY_RUN([
+#ifdef __BEOS__
+#include <inttypes.h>
+#endif
+#include <sys/types.h>
+uint16_t foo;
+int main() {return 0;}
+],
+has_uint16_t=yes,
+has_uint16_t=no,
+has_uint16_t=no
+)])
+AC_MSG_RESULT($has_uint16_t)
+
AC_MSG_CHECKING(for u_int32_t)
AC_CACHE_VAL(has_u_int32_t,
[AC_TRY_RUN([
@@ -143,6 +159,22 @@ has_u_int32_t=no
)])
AC_MSG_RESULT($has_u_int32_t)
+AC_MSG_CHECKING(for u_int16_t)
+AC_CACHE_VAL(has_u_int16_t,
+[AC_TRY_RUN([
+#ifdef __BEOS__
+#include <inttypes.h>
+#endif
+#include <sys/types.h>
+u_int16_t foo;
+int main() {return 0;}
+],
+has_u_int16_t=yes,
+has_u_int16_t=no,
+has_u_int16_t=no
+)])
+AC_MSG_RESULT($has_u_int16_t)
+
AC_MSG_CHECKING(for int64_t)
AC_CACHE_VAL(has_int64_t,
[AC_TRY_RUN([
@@ -198,6 +230,20 @@ else
fi
fi
+if test x$has_uint16_t = "xyes" ; then
+ USIZE16="uint16_t"
+else
+ if test x$has_u_int16_t = "xyes" ; then
+ USIZE16="u_int16_t"
+ else
+ case 2 in
+ $ac_cv_sizeof_short) USIZE16="unsigned short";;
+ $ac_cv_sizeof_int) USIZE16="unsigned int";;
+ $ac_cv_sizeof_long) USIZE16="unsigned long";;
+ esac
+ fi
+fi
+
if test x$has_int64_t = "xyes" ; then
SIZE64="int64_t"
else
@@ -211,6 +257,9 @@ fi
if test -z "$SIZE16"; then
AC_MSG_ERROR(No 16 bit type found on this platform!)
fi
+if test -z "$USIZE16"; then
+ AC_MSG_ERROR(No unsigned 16 bit type found on this platform!)
+fi
if test -z "$SIZE32"; then
AC_MSG_ERROR(No 32 bit type found on this platform!)
fi
@@ -228,6 +277,7 @@ dnl Make substitutions
AC_SUBST(LIBTOOL_DEPS)
AC_SUBST(SIZE16)
+AC_SUBST(USIZE16)
AC_SUBST(SIZE32)
AC_SUBST(USIZE32)
AC_SUBST(SIZE64)