summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorivo <ivo@xiph.org>2008-06-04 03:27:18 +0000
committerivo <ivo@xiph.org>2008-06-04 03:27:18 +0000
commitff8cdf9a389e732a602d89f38fe75ad197b7c6fb (patch)
treebbf9fd5a877ed933345bd71f1b4bbe9fa11659a7 /configure.in
parent780f7f8120ba1606c587e5b12ad61a0f86ace330 (diff)
downloadogg-ff8cdf9a389e732a602d89f38fe75ad197b7c6fb.tar.gz
Build support for Haiku. Patch by scottmc at gmail. Closes #1371.
git-svn-id: http://svn.xiph.org/trunk/ogg@14997 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 33f19b9..19561a6 100644
--- a/configure.in
+++ b/configure.in
@@ -84,7 +84,7 @@ dnl Check for types
AC_MSG_CHECKING(for int16_t)
AC_CACHE_VAL(has_int16_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>
@@ -100,7 +100,7 @@ AC_MSG_RESULT($has_int16_t)
AC_MSG_CHECKING(for int32_t)
AC_CACHE_VAL(has_int32_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>
@@ -116,7 +116,7 @@ AC_MSG_RESULT($has_int32_t)
AC_MSG_CHECKING(for uint32_t)
AC_CACHE_VAL(has_uint32_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>
@@ -132,7 +132,7 @@ AC_MSG_RESULT($has_uint32_t)
AC_MSG_CHECKING(for uint16_t)
AC_CACHE_VAL(has_uint16_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>
@@ -148,7 +148,7 @@ AC_MSG_RESULT($has_uint16_t)
AC_MSG_CHECKING(for u_int32_t)
AC_CACHE_VAL(has_u_int32_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>
@@ -164,7 +164,7 @@ AC_MSG_RESULT($has_u_int32_t)
AC_MSG_CHECKING(for u_int16_t)
AC_CACHE_VAL(has_u_int16_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>
@@ -180,7 +180,7 @@ AC_MSG_RESULT($has_u_int16_t)
AC_MSG_CHECKING(for int64_t)
AC_CACHE_VAL(has_int64_t,
[AC_TRY_RUN([
-#ifdef __BEOS__
+#if defined __BEOS__ && !defined __HAIKU__
#include <inttypes.h>
#endif
#include <sys/types.h>