summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorerikd <erikd@xiph.org>2008-04-13 12:26:40 +0000
committererikd <erikd@xiph.org>2008-04-13 12:26:40 +0000
commit537fd89ed20bd6ec7a156cfc273ef309f407fd40 (patch)
tree3de7cd347260fe1d30246af9e88751d75dea224e /src/Makefile.am
parent68c94dc9f70c3c5b0f68d75b0d5d4cc61eada7e2 (diff)
downloadogg-537fd89ed20bd6ec7a156cfc273ef309f407fd40.tar.gz
Minor fixes to allow cross compiling from Linux to windows and running the tests under Wine.
git-svn-id: http://svn.xiph.org/trunk/ogg@14725 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a964e3f..b207e78 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,9 @@ test_bitwise_CFLAGS = -D_V_SELFTEST
test_framing_SOURCES = framing.c
test_framing_CFLAGS = -D_V_SELFTEST
-TESTS = test_framing test_bitwise
+check: $(noinst_PROGRAMS)
+ ./test_bitwise$(EXEEXT)
+ ./test_framing$(EXEEXT)
debug:
$(MAKE) all CFLAGS="@DEBUG@"