summaryrefslogtreecommitdiff
path: root/libopeniscsiusr/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libopeniscsiusr/tests/meson.build')
-rw-r--r--libopeniscsiusr/tests/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/libopeniscsiusr/tests/meson.build b/libopeniscsiusr/tests/meson.build
new file mode 100644
index 0000000..d958c5c
--- /dev/null
+++ b/libopeniscsiusr/tests/meson.build
@@ -0,0 +1,16 @@
+# tests for libopeniscsiusr
+
+# create an assocaitive array, where the
+# thing being tested is the "key", and the
+# source file for it is the "value
+
+test_subjects = [
+ 'context',
+ 'iface',
+ 'node',
+ 'session']
+
+test_arr = {}
+foreach s: test_subjects
+ test_arr += {s: files('test_' + s + '.c')}
+endforeach