summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2012-12-13 08:18:56 +1100
committerDamien Miller <djm@mindrot.org>2012-12-13 08:18:56 +1100
commit25a02b0c95e01bc331267a1db0f62d3cbd7a0897 (patch)
treee968ae08dad316203054e909841d3b8367cc3b79 /configure.ac
parent8c05da3326fef892d993f0cd91808f2daf4d6a5f (diff)
downloadopenssh-git-25a02b0c95e01bc331267a1db0f62d3cbd7a0897.tar.gz
- (djm) [configure.ac cipher-ctr.c] Adapt EVP AES CTR change to retain our
compat code for older OpenSSL
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8b32e40c..64c231b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.498 2012/12/03 01:35:55 djm Exp $
+# $Id: configure.ac,v 1.499 2012/12/12 21:18:56 djm Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
-AC_REVISION($Revision: 1.498 $)
+AC_REVISION($Revision: 1.499 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_LANG([C])
@@ -2299,6 +2299,27 @@ AC_LINK_IFELSE(
]
)
+# Check for OpenSSL with EVP_aes_*ctr
+AC_MSG_CHECKING([whether OpenSSL has AES CTR via EVP])
+AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM([[
+#include <string.h>
+#include <openssl/evp.h>
+ ]], [[
+ exit(EVP_aes_128_ctr() == NULL ||
+ EVP_aes_192_cbc() == NULL ||
+ EVP_aes_256_cbc() == NULL);
+ ]])],
+ [
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([OPENSSL_HAVE_EVPCTR], [1],
+ [libcrypto has EVP AES CTR])
+ ],
+ [
+ AC_MSG_RESULT([no])
+ ]
+)
+
AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[