summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2022-08-05 13:12:27 +1000
committerDarren Tucker <dtucker@dtucker.net>2022-08-05 13:12:27 +1000
commit3d3a932a019aedfb891e0779bb4990cd5008a390 (patch)
tree403471b1c4239b4ba73cc8455c0fc59fd1d9a0b3 /configure.ac
parent9385d277b787403be9dfcb229cf372202496d2f3 (diff)
downloadopenssh-git-3d3a932a019aedfb891e0779bb4990cd5008a390.tar.gz
Factor out getrnd() and rename to getentropy().
Factor out the arc4random seeding into its own file and change the interface to match getentropy. Use native getentropy if available. This will make it easier to resync OpenBSD changes to arc4random. Prompted by bz#3467, ok djm@.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e49e163b..c36aee2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1879,6 +1879,7 @@ AC_CHECK_FUNCS([ \
futimes \
getaddrinfo \
getcwd \
+ getentropy \
getgrouplist \
getline \
getnameinfo \
@@ -2110,7 +2111,7 @@ AC_CHECK_DECLS([O_NONBLOCK], , ,
#endif
])
-AC_CHECK_DECLS([ftruncate], , ,
+AC_CHECK_DECLS([ftruncate, getentropy], , ,
[
#include <sys/types.h>
#include <unistd.h>