summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-06 04:47:35 +0000
committerDarren Tucker <dtucker@dtucker.net>2022-11-06 18:51:52 +1100
commit40b0a5eb6e3edfa2886b60c09c7803353b0cc7f5 (patch)
treef34c9cdce3224ef1bcd912c6a44636a264b273e6 /configure.ac
parent6b17e128879ec6cc32ca2c28b5d894b4aa72e32d (diff)
downloadopenssh-git-40b0a5eb6e3edfa2886b60c09c7803353b0cc7f5.tar.gz
configure.ac: Add <pty.h> include for openpty
Another Clang 16ish fix (which makes -Wimplicit-function-declaration an error by default). github PR#355. See: 2efd71da49b9cfeab7987058cf5919e473ff466b See: be197635329feb839865fdc738e34e24afd1fca8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e77ecfc..1866aea5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2373,6 +2373,9 @@ if test ! -z "$check_for_openpty_ctty_bug"; then
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
+#ifdef HAVE_PTY_H
+# include <pty.h>
+#endif
#include <sys/fcntl.h>
#include <sys/types.h>
#include <sys/wait.h>