summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2023-01-07 10:34:18 +1100
committerDarren Tucker <dtucker@dtucker.net>2023-01-07 10:34:18 +1100
commit5532e010a0eeb6aa264396514f9aed7948471538 (patch)
tree418c3f72b7c105e7f122ef4d6bd21ea846a55511 /configure.ac
parent5d7b16cff48598d5908db970bfdc9ff9326142c8 (diff)
downloadopenssh-git-5532e010a0eeb6aa264396514f9aed7948471538.tar.gz
Check openssl_bin path is executable before using.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index be8d9ad8..f6802500 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2696,14 +2696,11 @@ AC_ARG_WITH([ssl-dir],
esac
if test -d "$withval/lib"; then
libcrypto_path="${withval}/lib"
- openssl_bin="${withval}/bin/openssl"
elif test -d "$withval/lib64"; then
libcrypto_path="$withval/lib64"
- openssl_bin="${withval}/bin/openssl"
else
# Built but not installed
libcrypto_path="${withval}"
- openssl_bin="${withval}/apps/openssl"
fi
if test -n "${rpath_opt}"; then
LDFLAGS="-L${libcrypto_path} ${rpath_opt}${libcrypto_path} ${LDFLAGS}"
@@ -2715,6 +2712,11 @@ AC_ARG_WITH([ssl-dir],
else
CPPFLAGS="-I${withval} ${CPPFLAGS}"
fi
+ if test -x "${withval}/bin/openssl"; then
+ openssl_bin="${withval}/bin/openssl"
+ elif test -x "${withval}/apps/openssl"; then
+ openssl_bin="${withval}/apps/openssl"
+ fi
fi
]
)