summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHarmen Stoppels <harmenstoppels@gmail.com>2022-10-13 16:08:46 +0200
committerDarren Tucker <dtucker@dtucker.net>2022-10-14 07:37:16 +1100
commit5eb796a369c64f18d55a6ae9b1fa9b35eea237fb (patch)
tree007cd2fc7b57e9edd296034404da9e721fb3df41 /configure.ac
parentc64b62338b46ffa08839f05f21ad69fa6234dc17 (diff)
downloadopenssh-git-5eb796a369c64f18d55a6ae9b1fa9b35eea237fb.tar.gz
Fix snprintf configure test for clang 15
Clang 15 -Wimplicit-int defaults to an error in C99 mode and above. A handful of tests have "main(..." and not "int main(..." which caused the tests to produce incorrect results.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index de60a1b1..165c49de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -713,7 +713,7 @@ case "$host" in
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <mach-o/dyld.h>
#include <stdlib.h>
-main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
+int main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
exit(0);
else
exit(1);
@@ -4259,7 +4259,7 @@ dnl test snprintf (broken on SCO w/gcc)
#include <stdlib.h>
#include <string.h>
#ifdef HAVE_SNPRINTF
-main()
+int main()
{
char buf[50];
char expected_out[50];
@@ -4276,7 +4276,7 @@ main()
exit(0);
}
#else
-main() { exit(0); }
+int main() { exit(0); }
#endif
]])], [ true ], [ AC_DEFINE([BROKEN_SNPRINTF]) ],
AC_MSG_WARN([cross compiling: Assuming working snprintf()])