summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2022-03-08 20:04:06 +1100
committerDarren Tucker <dtucker@dtucker.net>2022-03-08 20:04:06 +1100
commit8cf5275452a950869cb90eeac7d220b01f77b12e (patch)
treeb53d9d891a8095561de096d78a8e44feee4d2aa6 /configure.ac
parent379b30120da53d7c84aa8299c26b18c51c2a0dac (diff)
downloadopenssh-git-8cf5275452a950869cb90eeac7d220b01f77b12e.tar.gz
Default to not using sandbox when cross compiling.
On most systems poll(2) does not work when the number of FDs is reduced with setrlimit, so assume it doesn't when cross compiling and we can't run the test. bz#3398.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 17fb1e60..a165d087 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3574,8 +3574,8 @@ AC_RUN_IFELSE(
select_works_with_rlimit=yes],
[AC_MSG_RESULT([no])
select_works_with_rlimit=no],
- [AC_MSG_WARN([cross compiling: assuming yes])
- select_works_with_rlimit=yes]
+ [AC_MSG_WARN([cross compiling: assuming no])
+ select_works_with_rlimit=no]
)
AC_CHECK_MEMBERS([struct pollfd.fd], [], [], [[