summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordjm@openbsd.org <djm@openbsd.org>2020-06-26 05:42:16 +0000
committerDamien Miller <djm@mindrot.org>2020-06-26 15:44:47 +1000
commit976c4f86286d52a0cb2aadf4a095d379c0da752e (patch)
tree39f721d68c5e000b5943a3d864863cb4dd9b0752 /configure.ac
parent32b2502a9dfdfded1ccdc1fd6dc2b3fe41bfc205 (diff)
downloadopenssh-git-976c4f86286d52a0cb2aadf4a095d379c0da752e.tar.gz
upstream: avoid spurious error message when ssh-keygen creates files
outside ~/.ssh; with dtucker@ OpenBSD-Commit-ID: ac0c662d44607e00ec78c266ee60752beb1c7e08
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0ea85bed..d6edb24f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4516,13 +4516,10 @@ AC_ARG_WITH([selinux],
LIBS="$LIBS -lselinux"
],
AC_MSG_ERROR([SELinux support requires libselinux library]))
- SSHLIBS="$SSHLIBS $LIBSELINUX"
- SSHDLIBS="$SSHDLIBS $LIBSELINUX"
AC_CHECK_FUNCS([getseuserbyname get_default_context_with_level])
- LIBS="$save_LIBS"
+ LIBS="$save_LIBS $LIBSELINUX"
fi ]
)
-AC_SUBST([SSHLIBS])
AC_SUBST([SSHDLIBS])
# Check whether user wants Kerberos 5 support
@@ -5483,9 +5480,6 @@ echo " Libraries: ${LIBS}"
if test ! -z "${SSHDLIBS}"; then
echo " +for sshd: ${SSHDLIBS}"
fi
-if test ! -z "${SSHLIBS}"; then
-echo " +for ssh: ${SSHLIBS}"
-fi
echo ""