summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2000-03-05 16:10:45 +1100
committerDamien Miller <djm@mindrot.org>2000-03-05 16:10:45 +1100
commitfac99cd12a9b4480284c4d4229b2e842bc1065f7 (patch)
treef562535463ee9923dd3ba71e823a888ed661d4cb /configure.in
parent01bedb83b1faddd7d9dd136bfcd474e1608af8f7 (diff)
downloadopenssh-git-fac99cd12a9b4480284c4d4229b2e842bc1065f7.tar.gz
- Explicitly seed OpenSSL's PRNG before checking rsa_alive()
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e5bdc445..c93811c7 100644
--- a/configure.in
+++ b/configure.in
@@ -160,7 +160,9 @@ for ssldir in "" $tryssldir /usr /usr/local/openssl /usr/lib/openssl /usr/local/
#include <openssl/bn.h>
#include <openssl/sha.h>
int main(void)
- {RSA *key;key=RSA_generate_key(32,3,NULL,NULL);return(key==NULL);}
+ {RSA *key; char seed[2048];memset(seed, 0, sizeof(seed));
+ RAND_seed(seed, sizeof(seed));key=RSA_generate_key(32,3,NULL,NULL);
+ return(key==NULL);}
],
[
AC_DEFINE(HAVE_OPENSSL)
@@ -174,7 +176,9 @@ for ssldir in "" $tryssldir /usr /usr/local/openssl /usr/lib/openssl /usr/local/
#include <ssl/bn.h>
#include <ssl/sha.h>
int main(void)
- {RSA *key;key=RSA_generate_key(32,3,NULL,NULL);return(key==NULL);}
+ {RSA *key; char seed[2048];memset(seed, 0, sizeof(seed));
+ RAND_seed(seed, sizeof(seed));key=RSA_generate_key(32,3,NULL,NULL);
+ return(key==NULL);}
],
[
AC_DEFINE(HAVE_SSL)