summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index be8d9ad8..f6802500 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2696,14 +2696,11 @@ AC_ARG_WITH([ssl-dir],
esac
if test -d "$withval/lib"; then
libcrypto_path="${withval}/lib"
- openssl_bin="${withval}/bin/openssl"
elif test -d "$withval/lib64"; then
libcrypto_path="$withval/lib64"
- openssl_bin="${withval}/bin/openssl"
else
# Built but not installed
libcrypto_path="${withval}"
- openssl_bin="${withval}/apps/openssl"
fi
if test -n "${rpath_opt}"; then
LDFLAGS="-L${libcrypto_path} ${rpath_opt}${libcrypto_path} ${LDFLAGS}"
@@ -2715,6 +2712,11 @@ AC_ARG_WITH([ssl-dir],
else
CPPFLAGS="-I${withval} ${CPPFLAGS}"
fi
+ if test -x "${withval}/bin/openssl"; then
+ openssl_bin="${withval}/bin/openssl"
+ elif test -x "${withval}/apps/openssl"; then
+ openssl_bin="${withval}/apps/openssl"
+ fi
fi
]
)