summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordjm <djm>2014-01-25 22:39:53 +0000
committerdjm <djm>2014-01-25 22:39:53 +0000
commitd899bbe1f4a8f480ae992b0ac1877fab8cc0e42e (patch)
treeccae796132a3253eeaa04a1437a69d128325afe0 /configure.ac
parent913a4df497e30cfd71e9d7b3b1af283fe4d557f1 (diff)
downloadopenssh-d899bbe1f4a8f480ae992b0ac1877fab8cc0e42e.tar.gz
- (djm) [configure.ac sandbox-capsicum.c sandbox-rlimit.c] Disable
RLIMIT_NOFILE pseudo-sandbox on FreeBSD. In some configurations, libc will attempt to open additional file descriptors for crypto offload and crash if they cannot be opened.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5e5e4d13..4a398418 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.562 2014/01/25 02:16:59 djm Exp $
+# $Id: configure.ac,v 1.563 2014/01/25 22:39:53 djm Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
-AC_REVISION($Revision: 1.562 $)
+AC_REVISION($Revision: 1.563 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_LANG([C])
@@ -780,6 +780,9 @@ mips-sony-bsd|mips-sony-newsos4)
AC_DEFINE([BROKEN_STRNVIS], [1],
[FreeBSD strnvis argument order is swapped compared to OpenBSD])
TEST_MALLOC_OPTIONS="AJRX"
+ # Preauth crypto occasionally uses file descriptors for crypto offload
+ # and will crash if they cannot be opened.
+ AC_DEFINE([SANDBOX_SKIP_RLIMIT_NOFILE])
;;
*-*-bsdi*)
AC_DEFINE([SETEUID_BREAKS_SETUID])