summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorzhurong <aaronzhu1121@gmail.com>2020-04-11 00:57:21 -0700
committerzhurong <aaronzhu1121@gmail.com>2020-04-11 00:57:21 -0700
commitbc9ef4a2a4d2286249057dfe9bb77604ff3b6885 (patch)
treeb0c38ea8c82f5bd3aac0c507504ec69ad573ab38 /setup.cfg
parent4fafac840468ab277ac00d919af50740f1ea600a (diff)
downloadceilometer-bc9ef4a2a4d2286249057dfe9bb77604ff3b6885.tar.gz
Cleanup py27 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo * Some other sections are obsolete - Update classifiers - Update requirements, no need for python_version anymore Change-Id: I93294c42a967ca19b9b04ead9cd636b52f1cc038
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg10
1 files changed, 3 insertions, 7 deletions
diff --git a/setup.cfg b/setup.cfg
index dd438c07..5fdca396 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -7,6 +7,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/ceilometer/latest/
+python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -14,15 +15,13 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Topic :: System :: Monitoring
-[global]
-setup-hooks =
- pbr.hooks.setup_hook
-
[files]
packages =
ceilometer
@@ -239,9 +238,6 @@ oslo.config.opts =
ceilometer = ceilometer.opts:list_opts
ceilometer-auth = ceilometer.opts:list_keystoneauth_opts
-[build_sphinx]
-warning-is-error = False
-
[extract_messages]
keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg