summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-08-13 12:28:31 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-08-14 12:47:21 -0400
commit039f3d893dae74f1d3b3b0bca6f60904ae4a9b15 (patch)
tree51d252d7cf23f65674804186c1fabe56f3e8191c /setup.py
parent867f168f615b995143e5a748ac833d2e9ed5f35b (diff)
downloadceilometer-039f3d893dae74f1d3b3b0bca6f60904ae4a9b15.tar.gz
Add separate notification handler for instance flavor
This notification handler records a meter event with the instance flavor included, making it easier to query for the amount of time an instance existed as a specific flavor. Change-Id: Ic162ac021f864c2a98c47127288867e940469ceb Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 726d85f0..c3cd0d70 100755
--- a/setup.py
+++ b/setup.py
@@ -38,6 +38,7 @@ setuptools.setup(
entry_points=textwrap.dedent("""
[ceilometer.collector.compute]
instance = ceilometer.compute.notifications:Instance
+ instance_flavor = ceilometer.compute.notifications:InstanceFlavor
memory = ceilometer.compute.notifications:Memory
vcpus = ceilometer.compute.notifications:VCpus
root_disk_size = ceilometer.compute.notifications:RootDiskSize