summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChuck Short <chuck.short@canonical.com>2013-03-04 09:33:33 -0600
committerChuck Short <chuck.short@canonical.com>2013-03-04 11:40:42 -0600
commit34cb09d9b273a104c6086a94b86a66789a3a0079 (patch)
tree119ba0604f30bcec12ec7525a421c4dde6e76818 /setup.py
parent346c4248e4cf667674accae0d999b473be1f0486 (diff)
downloadceilometer-34cb09d9b273a104c6086a94b86a66789a3a0079.tar.gz
Exclude tests when installing ceilometer
Dont include the tests directory when installing ceilometer as they might conflict with other poorly installed packages on the users systems. Fixes LP: #1102110 Signed-off-by Chuck Short <chuck.short@canonical.com> Change-Id: Ia8b0477af72b30dcf54b4751a51bbb460a7a90f4
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9fe04fb1..2954d548 100755
--- a/setup.py
+++ b/setup.py
@@ -70,6 +70,7 @@ setuptools.setup(
directories("ceilometer/api/static")
+ directories("ceilometer/api/templates"),
},
+ exclude_package_data={'': ['tests/*']},
include_package_data=True,
test_suite='nose.collector',