summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFrançois Rossigneux <francois.rossigneux@inria.fr>2013-01-07 17:15:13 +0100
committerGerrit Code Review <review@openstack.org>2013-01-16 10:33:28 +0000
commit49c4fb39f81c173f3a28c47cbb1415792ad4d4bb (patch)
treefb4ad36b26beeac08e822cd7acc18a89f1013914 /setup.py
parent51c8a8e55cc43ef5774c42ce38c962cb2526acfb (diff)
downloadceilometer-49c4fb39f81c173f3a28c47cbb1415792ad4d4bb.tar.gz
Add Kwapi pollster (energy monitoring).
Given that my blueprint is not publicly available, I summarize it here. Kwapi (kilowatt API) contains the following modules: - Drivers: receive values from wattmeters and forward them on a bus (ZeroMQ). Wattmeter drivers are specific to each wattmeters (Wattsup, OmegaWatt, etc). - Plugins: listen the bus and process received data. Currently, there is two plugins: the ceilometer plugin (REST API) and a visualization plugin (build graphs with RRDtool). Kwapi is part of the XLcloud project (HPC cloud). http://www.xlcloud.org Repository: https://github.com/stackforge/kwapi Change-Id: Ieaaa1db9c8c569b6ee9f0815e03879f8b3f3e282
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d2c41ef4..f37b6240 100755
--- a/setup.py
+++ b/setup.py
@@ -121,6 +121,7 @@ setuptools.setup(
image = ceilometer.image.glance:ImagePollster
image_size = ceilometer.image.glance:ImageSizePollster
objectstore = ceilometer.objectstore.swift:SwiftPollster
+ kwapi = ceilometer.energy.kwapi:KwapiPollster
[ceilometer.storage]
log = ceilometer.storage.impl_log:LogStorage