summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-10-18 06:13:51 -0700
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-10-18 06:13:51 -0700
commit4d648d7380526572353066b86853c5b30edaec76 (patch)
tree31d584f6e2b5e5156624c79d33056111da9d7c6a /setup.py
parent6bc3a13d931a49ae6cf9330872e032798a4ddbd1 (diff)
downloadceilometer-4d648d7380526572353066b86853c5b30edaec76.tar.gz
Add OpenStack trove classifier for PyPI
Add "Environment :: OpenStack" classifier for the PyPI catalog. Change-Id: I1ebbc684853203abba72ef72d63999be58870f3e Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index da1d8670..2b567179 100755
--- a/setup.py
+++ b/setup.py
@@ -45,6 +45,7 @@ setuptools.setup(
classifiers=[
'Development Status :: 3 - Alpha',
'Framework :: Setuptools Plugin',
+ 'Environment :: OpenStack',
'Intended Audience :: Information Technology',
'Intended Audience :: System Administrators',
'License :: OSI Approved :: Apache Software License',
@@ -73,6 +74,8 @@ setuptools.setup(
install_requires=requires,
dependency_links=depend_links,
+ zip_safe=False,
+
entry_points=textwrap.dedent("""
[ceilometer.collector]
instance = ceilometer.compute.notifications:Instance