summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2013-02-20 18:47:13 -0500
committerDoug Hellmann <doug.hellmann@dreamhost.com>2013-02-26 14:22:27 -0500
commit7d8bd50d08f40475bbe49e5066dde84c06c9c6fd (patch)
treec9db18f9f7c513a44506d382422cc60722692aa3 /setup.py
parent1d44a182cba71af1f4ef789f8fb973f70e5e1133 (diff)
downloadceilometer-7d8bd50d08f40475bbe49e5066dde84c06c9c6fd.tar.gz
Decouple the nova notifier from ceilometer code
The move to oslo.config introduced a conflict in the nova notifier because both nova and ceilometer have copies of the openstack.common.rpc library and define an option for the AMQP exchange name for the project. This changeset decouples the notifier plugin in ceilometer from most of the ceilometer code, to remove that conflict. The nova notifier is rewritten to emit a new notification message with event type `compute.instance.delete.samples` instead of making the old RPC calls directly to the ceilometer collector, and a notification listener plugin is provided to convert those messages to sample data. The notifier implementations are split between the one that worked in folsom and the one that works in grizzly to maintain backwards compatibility. get_hypervisor_inspector() is moved to a location where it can be imported both by the compute agent manager and the notifier plugin. The definition of `disabled_compute_pollsters` option is also moved for the same reason. The tox configuration is changed to run the nova notifier tests separately from the other tests, since nose cannot import nova and ceilometer code in the same process. bug 1130952 Change-Id: I39ba4564c9c14f09dbdd768d7a83f6940e3942ad Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e2c156d9..9fe04fb1 100755
--- a/setup.py
+++ b/setup.py
@@ -91,6 +91,7 @@ setuptools.setup(
[ceilometer.collector]
instance = ceilometer.compute.notifications:Instance
instance_flavor = ceilometer.compute.notifications:InstanceFlavor
+ instance_delete = ceilometer.compute.notifications:InstanceDelete
memory = ceilometer.compute.notifications:Memory
vcpus = ceilometer.compute.notifications:VCpus
disk_root_size = ceilometer.compute.notifications:RootDiskSize