summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorzhurong <aaronzhu1121@gmail.com>2020-04-11 00:57:21 -0700
committerzhurong <aaronzhu1121@gmail.com>2020-04-11 00:57:21 -0700
commitbc9ef4a2a4d2286249057dfe9bb77604ff3b6885 (patch)
treeb0c38ea8c82f5bd3aac0c507504ec69ad573ab38 /setup.py
parent4fafac840468ab277ac00d919af50740f1ea600a (diff)
downloadceilometer-bc9ef4a2a4d2286249057dfe9bb77604ff3b6885.tar.gz
Cleanup py27 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo * Some other sections are obsolete - Update classifiers - Update requirements, no need for python_version anymore Change-Id: I93294c42a967ca19b9b04ead9cd636b52f1cc038
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 1 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 782bb21f..cd35c3c3 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
- setup_requires=['pbr>=1.8'],
+ setup_requires=['pbr>=2.0.0'],
pbr=True)