summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-09-28 15:44:29 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-09-28 17:43:21 -0400
commitcafeb43f28bd167a4dc4fcb913fe758ed4305e7e (patch)
tree66e046887af17c80b53e4b08d2979c1813333d9a /setup.py
parent150436ac2106b0cc55cbc013cc858face7a71051 (diff)
downloadceilometer-cafeb43f28bd167a4dc4fcb913fe758ed4305e7e.tar.gz
Update packaging files
- Update the openstack.common.setup module - Update our openstack-common.conf to include setup.py in future updates - Use the common setup command class so the sdist command generates an AUTHORS file and ChangeLog Change-Id: I4469f0feaea5bb67022c6077bbea43110384f31b Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 436f3d23..8210a8ab 100755
--- a/setup.py
+++ b/setup.py
@@ -21,10 +21,10 @@ import textwrap
import setuptools
-from ceilometer.openstack.common import setup
+from ceilometer.openstack.common import setup as common_setup
-requires = setup.parse_requirements()
-depend_links = setup.parse_dependency_links(['tools/pip-requires.txt'])
+requires = common_setup.parse_requirements(['tools/pip-requires.txt'])
+depend_links = common_setup.parse_dependency_links(['tools/pip-requires.txt'])
setuptools.setup(
name='ceilometer',
@@ -34,6 +34,7 @@ setuptools.setup(
author_email='ceilometer@lists.launchpad.net',
url='https://launchpad.net/ceilometer',
packages=setuptools.find_packages(exclude=['bin']),
+ cmdclass=common_setup.get_cmdclass(),
include_package_data=True,
test_suite='nose.collector',
setup_requires=['setuptools-git>=0.4'],