summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-05-09 23:48:07 +0000
committerGordon Chung <chungg@ca.ibm.com>2014-05-20 12:59:42 -0400
commitf9af92a654ff8b998d3f7c40efec654f565cdafa (patch)
treea449e1848276104789d72a1cb288dcbdea4f1464 /setup.py
parent34db7d95c83a7698732d82820fa17ca8cea6284a (diff)
downloadceilometer-f9af92a654ff8b998d3f7c40efec654f565cdafa.tar.gz
Updated from global requirements
Change-Id: I7edbbb540599bbf51e07cffab1ebb058d88449ff
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f3..73637574 100755
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)