diff options
author | Andreas Jaeger <aj@suse.com> | 2020-04-17 10:50:32 +0200 |
---|---|---|
committer | Andreas Jaeger <aj@suse.com> | 2020-04-17 14:47:10 +0200 |
commit | 602e70cb552b984ea157c625051b1ac3f6565fe9 (patch) | |
tree | b32953c857cce98a82b4b3eeb8c076b9718dfa58 /setup.py | |
parent | 99c09bddceca754b550955db7e6786686316d525 (diff) | |
download | cinder-602e70cb552b984ea157c625051b1ac3f6565fe9.tar.gz |
Cleanup py27 support
This repo is now testing only with Python 3, so let's make
a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
know about the requirement
- Remove obsolete sections from setup.cfg
- Update classifiers
- Use newer openstackdocstheme, Sphinx, os-api-ref versions,
remove unused mock requirement
Change-Id: If7db350ea55a5edf7055ce049d27d9412b0e40bc
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 0 insertions, 9 deletions
@@ -13,17 +13,8 @@ # See the License for the specific language governing permissions and # limitations under the License. -# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT import setuptools -# In python < 2.7.4, a lazy loading of package `pbr` will break -# setuptools if some other modules registered functions in `atexit`. -# solution from: http://bugs.python.org/issue15881#msg170215 -try: - import multiprocessing # noqa -except ImportError: - pass - setuptools.setup( setup_requires=['pbr>=2.0.0'], pbr=True) |