summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKiall Mac Innes <kiall@managedit.ie>2012-09-25 08:00:23 +0100
committerKiall Mac Innes <kiall@managedit.ie>2012-09-25 08:04:13 +0100
commite851d552c80a450d2e564b2b20432fd656699d01 (patch)
tree71e0386b02d320e5d716e2a33fcc8860ce0aa027 /setup.py
downloaddesignate-e851d552c80a450d2e564b2b20432fd656699d01.tar.gz
Initial Public Commit.
The previous history contained sensitive imformation.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..40eff187
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/env python
+# Copyright 2012 Managed I.T.
+#
+# Author: Kiall Mac Innes <kiall@managedit.ie>
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may
+# not use this file except in compliance with the License. You may obtain
+# a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations
+# under the License.
+from setuptools import setup, find_packages
+
+setup(
+ name='moniker',
+ version='0.0',
+ description='DNS as a Service',
+ author='Kiall Mac Innes',
+ author_email='kiall@managedit.ie',
+ url='https://launchpad.net/moniker',
+ packages=find_packages(exclude=['bin']),
+ include_package_data=True,
+ test_suite='nose.collector',
+ setup_requires=['setuptools-git>=0.4'],
+ scripts=[
+ 'bin/moniker-agent-bind9',
+ 'bin/moniker-api',
+ 'bin/moniker-central',
+ ],
+)