summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSteven Hardy <shardy@redhat.com>2012-08-22 10:30:03 +0100
committerSteven Hardy <shardy@redhat.com>2012-08-31 18:27:48 +0100
commit311092a29468e085b89ed6f07a9e593bbe6b0f37 (patch)
tree10eb3575ead910c91753a889c6ec8a4589b509fb /setup.py
parent7a382d5ff1390aae91f5d4df633e4cf7e2e39006 (diff)
downloadheat-311092a29468e085b89ed6f07a9e593bbe6b0f37.tar.gz
heat API : Implement initial CloudWatch API
Initial AWS-compatible CloudWatch API implementation Supports the following API actions: - DescribeAlarms : describe alarm/watch details - ListMetrics : List watch metric datapoints - PutMetricData : Create metric datapoint - SetAlarmState : temporarily set alarm state Skeleton implementation of all other TODO actions which returns HeatAPINotImplementedError. Only basic filtering parameters supported at this time. Signed-off-by: Steven Hardy <shardy@redhat.com> Change-Id: I8628854a135fff07b675e85150ea0b50184ed2e1
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6cafbb08b..092c02032 100755
--- a/setup.py
+++ b/setup.py
@@ -45,6 +45,7 @@ setuptools.setup(
],
scripts=['bin/heat',
'bin/heat-api',
+ 'bin/heat-api-cloudwatch',
'bin/heat-boto',
'bin/heat-metadata',
'bin/heat-engine',