summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-10-23 11:25:18 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-10-23 11:25:32 -0400
commit8f44c3933e4c91146f3027bf1a40bc708efbe601 (patch)
tree7f361381d4f4ee9cdc1b1180a617e03ee0de5388 /setup.py
parentb0ec91127064e1431aa3d88beb35d08b4cd91821 (diff)
downloadkeystone-8f44c3933e4c91146f3027bf1a40bc708efbe601.tar.gz
Add trove classifiers for PyPI
Add classifiers so we can eventually register the project on PyPI to reserve the name, even though we won't release packages there. Change-Id: I9ef676ffd4a84cb149d7f5b6998c16c46e4181b8 Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 310723cde..34cd6d9fd 100644
--- a/setup.py
+++ b/setup.py
@@ -44,4 +44,14 @@ setup(name='keystone',
install_requires=requires,
dependency_links=depend_links,
test_suite='nose.collector',
+ classifiers=[
+ 'Environment :: OpenStack',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ ],
)