summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:41:29 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:41:29 +0000
commit373d72e2718608b5824f1c4c8b926206dc7f6146 (patch)
treee754c388b8b71798de30054047c3316c3dd3dafe /setup.py
parentffd0774f5d35e3eefe6534ab74e82ae203a07cf9 (diff)
downloadneutron-373d72e2718608b5824f1c4c8b926206dc7f6146.tar.gz
Updated from global requirements
Change-Id: I6090b1bde89b25eaa1aea94024b7f4225375e65e
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f32b..736375744d 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)