summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McClain <mark.mcclain@dreamhost.com>2012-08-20 10:18:01 -0400
committerMark McClain <mark.mcclain@dreamhost.com>2012-09-04 01:45:03 -0400
commit8e34320bbc844c42066b9499e6afff8feda1fa56 (patch)
tree2fd5ac73565c3dec3eb6d30c57755947a9d0d3b7 /setup.py
parentd8160e02bbccdf9ab89d644924203e4ae504c3bf (diff)
downloadneutron-8e34320bbc844c42066b9499e6afff8feda1fa56.tar.gz
Create utility to clean-up netns.
Fixes bug 1035366 Adds namespace clean up utility called quantum-netns-cleanup which can be used to remove old namespaces. The --force option can be used to remove all Quantum namespaces and any remaining devices. The force option is should not be run on a live Quantum systems. It is intended for cleaning up devstack a after running unstack.sh (ideally this will be added to unstack.sh in the future). Example cmd line when cleaning up a devstack install: quantum-netns-cleanup --config-file /etc/quantum/quantum.conf \ --config-file /etc/quantum/dhcp_agent.ini --force Change-Id: I6cf153df21e83bff2cde816db12b22102d1ba698
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7abb848b84..98fcbba263 100644
--- a/setup.py
+++ b/setup.py
@@ -102,6 +102,7 @@ setuptools.setup(
'quantum-dhcp-agent = quantum.agent.dhcp_agent:main',
'quantum-dhcp-agent-dnsmasq-lease-update ='
'quantum.agent.linux.dhcp:Dnsmasq.lease_update',
+ 'quantum-netns-cleanup = quantum.agent.netns_cleanup_util:main',
'quantum-l3-agent = quantum.agent.l3_nat_agent:main',
'quantum-linuxbridge-agent ='
'quantum.plugins.linuxbridge.agent.linuxbridge_quantum_agent:main',