summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEdgar Magana <emagana@gmail.com>2013-02-08 09:01:34 -0800
committerEdgar Magana <emagana@gmail.com>2013-02-10 07:49:48 -0800
commitf23a8a74b0c5d540d9b96678d53ef8c557630876 (patch)
tree6ecff2ce2b805936243b350f7de4de231764eebe /setup.py
parentbbef9ab0acb52b51b311adedbbb4d8b056550915 (diff)
downloadneutron-f23a8a74b0c5d540d9b96678d53ef8c557630876.tar.gz
PLUMgrid quantum plugin
PLUMgrid plugin supports Quantum Core V2 APIs over an infrastructure running PLUMgrid Network Virtualization Platform. The plugin will interact directly with the Hypervisor layer to provide all the networking functionality requested by Quantum APIs. It will be based on a controller-mode implementation were all resources state will be controlled and handled by the plugin. Implements: blueprint plumgrid-quantum-plugin Change-Id: I6bc8d32b83982e10f661913e85494468cf10e0e2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b46dbb5be4..f24e267122 100644
--- a/setup.py
+++ b/setup.py
@@ -52,6 +52,7 @@ ryu_plugin_config_path = 'etc/quantum/plugins/ryu'
meta_plugin_config_path = 'etc/quantum/plugins/metaplugin'
nec_plugin_config_path = 'etc/quantum/plugins/nec'
hyperv_plugin_config_path = 'etc/quantum/plugins/hyperv'
+plumgrid_plugin_config_path = 'etc/quantum/plugins/plumgrid'
if sys.platform == 'win32':
# Windows doesn't have an "/etc" directory equivalent
@@ -104,6 +105,8 @@ else:
(nec_plugin_config_path, ['etc/quantum/plugins/nec/nec.ini']),
(hyperv_plugin_config_path,
['etc/quantum/plugins/hyperv/hyperv_quantum_plugin.ini']),
+ (plumgrid_plugin_config_path,
+ ['etc/quantum/plugins/plumgrid/plumgrid.ini']),
]
ConsoleScripts = [