summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-02-07 14:32:15 -0800
committerMonty Taylor <mordred@inaugust.com>2012-02-08 19:30:39 -0800
commit4a4c274c834728a03bce7e5384c562321821eaf8 (patch)
tree99604197f834264e38cf3bdef6577f01d87bdb72 /setup.py
parent1815aaf13af1c5d6d4225fa0f8f4adb2b10548e6 (diff)
downloadnova-4a4c274c834728a03bce7e5384c562321821eaf8.tar.gz
Get rid of distutils.extra.
We moved to DistUtilsExtra because it promised a more automatic workflow from setup.py. It doesn't actually deliver though, and it also vomits warnings during setup.py usage, and also breaks pip integration. So this is going back to babel. Mostly folks shouldn't need to know anything about this. We'll need to update the translations import jobs in Jenkins, and we might need to add a corresponding translations upload job that runs post-merge. Translations installation doesn't fully work - but it actually wasn't fully working before. Getting this part of the project done now though is a pre-requisite for using tox for multi-python testing (tox starts by creating an sdist tarball and then installing it into the venv, which is just 100% broken with DistUtilsExtra) Change-Id: I126e1bcfab0656eab6ca10de67d3d2aaa8b844f3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 1 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 1276e0aee4..ec784d91f0 100644
--- a/setup.py
+++ b/setup.py
@@ -16,26 +16,12 @@
# License for the specific language governing permissions and limitations
# under the License.
-import gettext
import glob
import os
from setuptools import find_packages
-# In order to run the i18n commands for compiling and
-# installing message catalogs, we use DistUtilsExtra.
-# Don't make this a hard requirement, but warn that
-# i18n commands won't be available if DistUtilsExtra is
-# not installed...
-try:
- from DistUtilsExtra.auto import setup
-except ImportError:
- from setuptools import setup
- print "Warning: DistUtilsExtra required to use i18n builders. "
- print "To build nova with support for message catalogs, you need "
- print " https://launchpad.net/python-distutils-extra >= 2.18"
-
-gettext.install('nova', unicode=1)
+from setuptools import setup
from nova import version