summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2013-02-15 22:30:16 +0000
committerVishvananda Ishaya <vishvananda@gmail.com>2013-02-19 21:16:32 -0800
commit706a1370056ffccc2c8811fc1ac0679944564ece (patch)
tree0b71139bbf282e7909b0df37a69a2aaa8f3e32d2 /setup.py
parentd62205f316ad9490e1379e943972a007e071c688 (diff)
downloadnova-706a1370056ffccc2c8811fc1ac0679944564ece.tar.gz
Use oslo-config-2013.1b4
The cfg API is now available via the oslo-config library, so switch to it and remove the copied-and-pasted version. Add the 2013.1b4 tarball to tools/pip-requires - this will be changed to 'oslo-config>=2013.1' when oslo-config is published to pypi. This will happen in time for grizzly final. Add dependency_links to setup.py so that oslo-config can be installed from the tarball URL specified in pip-requires. Remove the 'deps = pep8==1.3.3' from tox.ini as it means all the other deps get installed with easy_install which can't install oslo-config from the URL. Make tools/hacking.py include oslo in IMPORT_EXCEPTIONS like it already does for paste. It turns out imp.find_module() doesn't correct handle namespace packages. Retain dummy cfg.py file until keystoneclient middleware has been updated (I18c450174277c8e2d15ed93879da6cd92074c27a). Change-Id: I4815aeb8a9341a31a250e920157f15ee15cfc5bc
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 54d62e409d..fd968eeb26 100644
--- a/setup.py
+++ b/setup.py
@@ -20,6 +20,7 @@ import setuptools
from nova.openstack.common import setup as common_setup
requires = common_setup.parse_requirements()
+depend_links = common_setup.parse_dependency_links()
project = 'nova'
setuptools.setup(
@@ -42,6 +43,7 @@ setuptools.setup(
cmdclass=common_setup.get_cmdclass(),
packages=setuptools.find_packages(exclude=['bin', 'smoketests']),
install_requires=requires,
+ dependency_links=depend_links,
include_package_data=True,
test_suite='nose.collector',
setup_requires=['setuptools_git>=0.4'],