summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjaypipes@gmail.com <>2011-04-26 14:17:09 -0700
committerjaypipes@gmail.com <>2011-04-26 14:17:09 -0700
commitc95aaaaefe11048990021d376dbca6460f19248c (patch)
tree25f80b95d0bbfb1f901fa0aba9f05c511fa48c95 /setup.py
parent5ea80e2f62e7a35967fc509aef8e7158577a2980 (diff)
downloadnova-c95aaaaefe11048990021d376dbca6460f19248c.tar.gz
Make the import of distutils.extra non-mandatory in setup.py. Just print a warning that i18n commands are not available...
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 11 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 194b551834..c165f40d72 100644
--- a/setup.py
+++ b/setup.py
@@ -25,14 +25,18 @@ import sys
from setuptools import find_packages
from setuptools.command.sdist import sdist
+# In order to run the i18n commands for compiling and
+# installing message catalogs, we use DistUtilsExtra.
+# Don't make this a hard requirement, but warn that
+# i18n commands won't be available if DistUtilsExtra is
+# not installed...
try:
- import DistUtilsExtra.auto
+ from DistUtilsExtra.auto import setup
except ImportError:
- print >> sys.stderr, 'To build nova you need '\
- 'https://launchpad.net/python-distutils-extra'
- sys.exit(1)
-assert DistUtilsExtra.auto.__version__ >= '2.18',\
- 'needs DistUtilsExtra.auto >= 2.18'
+ from setuptools import setup
+ print "Warning: DistUtilsExtra required to use i18n builders. "
+ print "To build nova with support for message catalogs, you need "
+ print " https://launchpad.net/python-distutils-extra >= 2.18"
gettext.install('nova', unicode=1)
@@ -102,7 +106,7 @@ def find_data_files(destdir, srcdir):
package_data += [(destdir, files)]
return package_data
-DistUtilsExtra.auto.setup(name='nova',
+setup(name='nova',
version=version.canonical_version_string(),
description='cloud computing fabric controller',
author='OpenStack',